config.php Host & Directory settings

Can anyone advise if this is how the config.php file should be?



The example shows '/store/cscart, but I do not have a store folder.



// Host and directory where cs-cart is installed on usual server

$cscart_http_host = ‘www.barnlightelectric.com’;

$cscart_http_dir = ‘/cscart’;



// Host and directory where cs-cart is installed on secure server

$cscart_https_host = ‘secure.barnlightelectric.com’;

$cscart_https_dir = ‘/secure_dir/cscart’;



Thanks,



Bryan

if the store is NOT in a sub-folder (i.e. www.domain.com/store)

then your config should look like this:


// Host and directory where cs-cart is installed on usual server
$cscart_http_host = 'www.barnlightelectric.com';
$cscart_http_dir = ' ';

// Host and directory where cs-cart is installed on secure server
$cscart_https_host = 'secure.barnlightelectric.com';
$cscart_https_dir = ' ';




I am not sure about the https (secure) link, in my case, it is the same URL

if your secure URL is as you have it denoted (secure.barnlight.com) you shouldn’t need the subfolders

Hi Mike,



Thank you for the reply. I believe I have fixed this issue as you advised above, but now I cannot log into the backend. When I go to www.barnlightelectric.com/admin.php and attempt to log in, it re-directs me to [url]http://http//www.barnlightelectric.com/admin.php[/url]. Would you know how I could fix this?

try clearing your template cache

it went there OK for me just now

Not sure of how to clear the template cache? I have cleared the browser cache but still get the double [B][url]http://http//[/url][/B][url]www.barnlightelectric.com/admin.php[/url] when attempting to log in with my username and password?



The issue is the double [url]http://http//[/url] which gives me a page cannot be found.

top right of your admin page

BUT, you can’t get to your admin page

:confused:

That is correct…I cannot get to the admin page. I am also having an issue where I put products into my cart, but when I go to checkout they are gone. I’m sure it is the result of some settings not being correct in the move to the new server. But, I cannot figure it out.

try taking out the secure in your config.php

(just put www.barnlight.com there)

then refresh your server after you upload


// Host and directory where cs-cart is installed on usual server
$cscart_http_host = 'www.barnlightelectric.com';
$cscart_http_dir = '';

// Host and directory where cs-cart is installed on secure server
$cscart_https_host = 'www.barnlightelectric.com';
$cscart_https_dir = '';

This is my current config.php:



// Host and directory where cs-cart is installed on usual server

$cscart_http_host = ‘http://www.barnlightelectric.com’;

$cscart_http_dir = ‘’;



// Host and directory where cs-cart is installed on secure server

$cscart_https_host = ‘https://www.barnlightelectric.com’;

$cscart_https_dir = ‘’;



Still not able to get into the back end and unable to add products to cart without them vanishing on checkout.

copy and paste the config I posted in #8



(the secure may be wrong, but it shouldn’t matter on the login if you haven’t activated secure login for admin

I copied and pasted the config you posted in #8, but was not able to log into the admin. It would not let me click the submit button.

well…the config is right

not sure what else is happening

sorry



:frowning:



maybe try removing the .htaccess? (just temporarily)



Also, I recall a thread with the http://http thingy

Mike, thanks for your help. I guess I will have to wait on cscart support, because I cannot figure this thing out. Maybe a few cold beers would help!

PASAFETY Found the solution in the config.php.



// Host and directory where cs-cart is installed on usual server

$cscart_http_host = ‘barnlightelectric.com’;

$cscart_http_dir = ‘’;



// Host and directory where cs-cart is installed on secure server

$cscart_https_host = ‘barnlightelectric.com’;

$cscart_https_dir = ‘’;



Thanks for everyones help!