Chicken / Egg Situation - Can't add blocks

I have an issue with the cart, some of the buttons to ‘Add’ - A new category or a New Block when pressed just make the ‘Loading…’ appear at the top of the page.

I contacted support and they say I have to buy the license or pay for support and they will fix it and I have my client who doesn’t want to buy a product that doesn’t work. He wants to go Magento and I am trying to convince him the Admin side of things will be better for him to maintain (and less support from me)

I have found all these posts loooking through 48 Pages of these threads.










All related to the same issue. The one with the asterix claims that CS Cart Supoprt fixed it for him by editing the DB as the error existed there.

“…I have fixed this bug on your server. It was caused by the incorrect information in the “cscart_products” table in the database. I corrected it…”

So apart from having no support it seems I, as well as others are being held over a barrel to pay before getting a working Product. This doesn’t seem fair or look good for a future relationship between user and supplier.

So please, somebody help me solve this problem or I will lose my clients confidence and you will lose an advocate for your product.

I have tried :

~ Applying chmod 777 to /var and its subfolders


~ disabling the ajax from dynamic html

~ Installing latest version of Java

~ Other browsers

~ Banging my head on the desk

HELP! - please.

This is most likely due to server restrictions or incorrect permissions

I can probably help you to resolve it if you create a phpinfo script and PM a link to me

Thanks Combs, I really appreciate this.


Server API CGI/FastCGI

Your server is running PHP as CGI so you will need to correct your file permissions. Files and directories should not be given 666 or 777 permissions on that server.

All directories should be set to 755

All files should be 644

If you still receive errors after that then try this as well

Open config.local.php and adjust the memory limit variable to 128 like this

```php @ini_set(‘memory_limit’, ‘128M’); ```Copy and paste this line right under the memory limit above

```php @ini_set(‘max_execution_time’, ‘60’); ```

Ok I have set ‘all’ folder as 755 and for the moment all ‘files’ in the var folder to 655.

This had no effect.

Also in the config.local.php the line you mentioned was different, it was :

[COLOR=#000000][COLOR=#007700]@[/COLOR][COLOR=#0000BB]ini_set[/COLOR][COLOR=#007700]([/COLOR][COLOR=#DD0000]'memory_limit'[/COLOR][COLOR=#007700], [/COLOR][COLOR=#DD0000]'48M'[/COLOR][COLOR=#007700]); [/COLOR][/COLOR][COLOR=#000000][COLOR=#007700]


so I have changed this to ‘128M’ and added the line below.

Still these buttons do nothing : Add feature / Add Filter / Add Group / Add Block / Add Item (Quick Links) / Add Item / Add Field (Profile) / Add Language / Add New (SEO Rules) / Add Subscriber - I just get the [COLOR=DarkGreen]‘Loading…’[/COLOR] appear at the top of the screen, nothing else.

But, these buttons do work : Add Category / Add Product / Add Cart/Catalogue Promotion / Add User / Add Post (Testimonials) (these did work before any changes though)

So it must be something to do with the action that has to take place using those particular buttons… it’s very odd.

Re-upload all the admin side skins and clear the cache, it should resolve the problems but if not let us know - Sno

hopefully you meant 644 on the file permissions

I should have told you to clear your caches after making those changes

Also check your browser’s “error console” to see if you have any javascript errors since the Loading box indicates an ajax request.

[quote name=‘snorocket’]Re-upload all the admin side skins and clear the cache, it should resolve the problems but if not let us know - Sno[/quote]

Doing that now.

[quote name=‘S-Combs’] hopefully you meant 644 on the file permissions[/quote]

Yes I did.

[quote name=‘tbirnseth’] Also check your browser’s “error console” to see if you have any javascript errors since the Loading box indicates an ajax request.[/quote]

Great point.

I got this warning

Warning: Unknown property ‘-moz-opacity’. Declaration dropped.

Source File: [URL][/URL]

Line: 230

…and these 2 errors when pressing the button

Error: xplSearch.engine is undefined

Source File: chrome://searchshield/content/overlay.js

Line: 968

Error: doc.location is null

Source File: chrome://searchshield/content/overlay.js

Line: 751

These erros were using Firefox, I have tested IE8 and I have the same issue but haven’t been able to find the error console

I’ll report back once I have reuploaded the Admin ‘Basic’ Skin folder.

Guys I really have to thank you for your prompt responses and suggestions. I uploaded all the admin files again and the buttons are working fine.

It’s hard to believe such a simple action resolved it, and to be honest I probably wouldn’t have considered doing it thinking it would affect the site.

Admin panel is also running quicker.

I really appreciate the responses and I hope any others suffering the same issue hit this post first.


Those JS/CSS errors can be safely ignored.

Glad you got things together.