Cdn Cloudfront Didn't Work For Me

Don’t know why, I’ve set it up and loads of Wordpress sites but in cs-cart the seems no place to configure what it should cache and what is shouldn’t. In my case it showed a JS file to test. That didn’t work but I thought what the hell enable it and see.

Stylesheets didn’t work on frontend or admin :-) slight panic while I searched the database cscart_settings_objects and changed IS_ENABLED to IS_DISABLED

Just posting for other idiots who like the risk :-)

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]Please check that these settings have the following values:[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]Viewer Protocol Policy - HTTPS Only[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]Origin Protocol Policy - Match Viewer[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]Forward Query Strings - Yes[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]http port - 80[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]https port - 443[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]on cloudfront…[/size][/font][/color]

Why would I want HTTPS only ? I don't use it.

It was the Forward Query Strings - Yes setting that was wrong.


great that you have solved :) sorry for https :) my mistake

I now have another problem, I decided to update some images. So naturally I went into the Admin desktop and edited the first product image. The product image does not now show on the product page. It seems the one on the CDN was deleted but the new one on the server has not replaced it. After 12 hours this product still no image.

I don't think I should need to rebuild either thumbnail cache or the main cache for this to work. At least I hope not.