Cart empties after clicking checkout

Hey all! I have a problem where the cart empties itself as soon as I click checkout. If I turn ssl off then it is fine and works but need the security of ssl. I tried the AOL fix with define(‘SKIP_SESSION_VALIDATION’, true); in the config file but this didnt seem to do anything. Ive tested in chrom firefox and safari. any help would be great or if anyone can test on there end.

store is here and running 2.0.10

[url]Equipment for mountain sports, climbing and occupational safety | EDELRID




I don’t know the answer, but can confirm your problem. Am using IE7.

What is interesting is that next to the cart symbol on the top of your pages, it says 3 items in the cart (the three I tested), but when you select view cart or check out, as you said, there is nothing there. When you continue shopping, the mini cart still has the three items listed when you expand the symbol.


Try turning off ajax add to cart.

tried turning off ajax but still get the same thing…huh. 1.35.4 works fine on the server at

sadly this is the last hurdle to switching over to 2.0 but I cant seem to figure it out. any other suggestions out there will be appreciated.

It does work fine and allows full checkout all the way through if I turn ssl off.

Still having tjis same problem. did a clean install to see if that was the problem but I still have teh same cart is empty issue.

Any ideas? is it my host? cart works fine and allows checkout if I turn SSL OFF.

see new clean install here. [url]EDELRID

submitted problem to cs cart but havent heard back yet.

I took a look and don’t really know what the problem is. I can tell you that I used to host with Omnis and I had quite a few issues and switched host. I still have most of my domain names registered there, but the hosting wasn’t great for CS-Cart.

Also I see that you have your SSL still on. I really don’t know, but maybe it has something to do with using a shared SSL cert. You might consider just picking up a SSL cert from GoDaddy or something. I think they are like $29.99 right now. If you got your own cert not only might it fix your problem, but your address won’t change.

I wish I could be more help.


I’m now seeing this same problem in my cart. I thought I had tested it in IE7 because I do have that on my PC but maybe I didn’t. Mine is 2.0.8 and working fine in FF3.6 without any issues. I haven’t tried it by turning off my SSL yet but I guess that will be a test for me to perform next. I don’t have a shared SSL but a dedicated one.


I realize that you really don’t want to upgrade, however, ya gotta realize that there were a slew of bug fixes (some quite serious) along the way up to 2.0.12. Some of them I believe were directly related to things such as the way cart sessions were handled, carts emptying for some reason, etc. etc. :wink:

Hi Struck,

It’s not that I don’t want to upgrade but I have a variety of changes that I would have to apply to each version as I upgrade plus I’m using memberships which I’ve heard had issues during upgrade due to change to “User Groups” and am very hard pressed for time right now to go through an upgrade. I’m going to work on installing a clean version of 2.0.8 somewhere and practice upgrading it to see where I might have any issues than I’ll work on getting my live site upgraded.

I fixed the problem of my cart emptying by applying the fix from this thread so I’m moving along happily at the moment. :slight_smile:

Thanks again for the reminder, though - it’s always appreciated!

I understand Stephanie, just don’t want to see you deal with any excess suffering along the way! :smiley:

If it helps, I can confirm that Memberships work just fine in 2.0.12 as we also have several in use!

Oh, it’s not that I don’t believe the User Groups work in 2.0.12 but I know I’ll probably have to unassign my customers and shipping options from their current Memberships before I upgrade to make it easier. :slight_smile:

[quote name=‘scase’]Oh, it’s not that I don’t believe the User Groups work in 2.0.12 but I know I’ll probably have to unassign my customers and shipping options from their current Memberships before I upgrade to make it easier. :)[/QUOTE]

Maybe not.

There was a problem with the Membership->Usergroups transition with the initial 2.0.8->2.0.9 upgrade. If I recall correctly, they released a second upgrade a few days later which resolved the problem.

Copy your 2.08 setup to a test site and just try doing the upgrade there. Worst case is that you will have wasted a little time; best case is that it works and you just need to incorporate your changes after the upgrade.


Hmmm…I’ll give that a try, Bob. I do recall the fix coming out for the 2.0.9 upgrade now that you mention it. That would be nice if it would work effortlessly!

Thanks for the tip!

I’ve been unable to replicate it myself, but have spoken to a score of customers over the past week who have spent several attempts adding books to their carts, clicking checkout, and finding the cart empties. For every customer who takes the time to get in touch about this, I can only assume there are ten other who choose to shop elsewhere as a result.

Has the source of the problem been found yet?

Thanks in advance!

I am running cs-cart 2.2.4 professional, and have had many customer reports of the cart emptying during checkout, and often when simply trying to add a second item to the cart. Anyway, this seems to be a cookie related issue, since the problem can be replicated by turning up the security settings in your browser to block cookies.

Having said that, I know that some customers have been unable to checkout and have then gone to buy with a competitor, whose website also uses cookies. So it can't be their security and privacy settings…it appears to be a problem with the way cs-cart handles cookies.

It seems to be more prevalent in IE, however some customers have had the same problem with Chrome.

Anybody got any ideas here?