Can't update some product code & qty inside the option combinations page

I have a new installation site with CS-cart 2.0.14. When Option combinations more than about 6 option combinations. I found that there are at least 2 option items that I can’t update their product code and qty inside the option combinations page. Even deleted them and re-created. Still the same problem!

I tried it on my another CS-cart 2.0.15 site with same option combinations. Everything work well! So, I tried to install or upgrade to 2.0.15, but this problem still be there for my new site…

Any tech. suggestions to fix this strange bug?

Got CS-cart tech. support feedback for it:

This problem seems to be a bug in your PHP version, not in the CS-Cart installation. So we can advise you to downgrade your PHP version to 5.2.x.

My New site’s php is version 5.2.13. Anyone know which 5.2.x is right for CS-cart???

Or you knew which Cs-cart program is used to update Option combinations.

Need your help!

Cs-Cart works just fine with PHP 5.2.13 but does have some problems with 5.3+

This could be caused by PHP limits but it sounds like something else I’ve encountered before. Check to see if your server is running Suhosin to enhance PHP security and if so its settings may need adjusted.

If you have access to your servers logs, you should be able to find the cause of this problem in one of these.



Hi S-Combs,

It sounds pro expert tip to me. Thanks for your expert tip. I will check my server settings and get back to you.

Hi S-Combs,

Unfortunately, I can’t access my servers logs with Netsol hosting control panel or FTP access… A little sad!

I aslo checked phpinfo, but can’t find any Suhosin or secuirty word inside…

Any other suggestion?

Suhosin should be listed in phpinfo with it’s own section near the bottom if it were installed. It has settings to limit data field submissions and is why I thought of it. There are other intrusion detection systems with similar settings so you should ask your host if they can find something within the server logs that will help you.

I don’t think this problem is caused by basic PHP settings but it could be. If you PM me a link to a phpinfo page, I’ll take a look.

I already contact my hosting support. Wish I can get some good news from them.

Thanks for your big help!

Hi S-Combs,

Finally, Cs-cart found the bug and made some code changes in the “product_options.php” under the “controllers/admin” directory. Everything works well!

Actually, I submit the support ticket to NetSol, but got nothing

feedback from them more than 10hrs.

Anyway, Thank you for big help!!!

I’m glad you got it worked out.

I did look through your phpinfo page and see that your host has some strict PHP memory and execution time limits set and also allow register globals which can be dangerous. You might want to consider another host before you have more problems in the future.

That is a good suggestion to consider, but boss only trust NetSOL and hosted with them more than 6 yrs…