Can't Get Products Into Cart

I am having problems getting my products into my cart. The first time I try to add a product to the cart I get a page that says my cart is empty. If I click back and then click add to cart again the product is added. Once one product is added to my cart than I can add as many products as I want on the first click. I do have a couple of mods that I have added to my site and I am running version 1.3.4 sp2. I have the thickbox mod, descriptive minicart mod, and the image tooltip mod. I don’t know what the problem is, but if anyone has an idea I would love to hear it.


Its something to do with the minicart mod for definate…

I have just been modding my cart and moved all my “cart sidebox”

I suffered the same problem but moved the code around a little and it worked.

I cannot be specific to which code etc as my .tpl files are now completely different, however I would save a copy of your “cart_pages/cart_status.tpl” and also “side_boxes/cart.tpl” then restore them and see if its ok.

Then I would re-apply the mod…

I know im stating the obvious, but saves you going round in circles.

Thanks SWS

I uploaded a backup copy of cart_status.tpl to the site and was able to add the products on the first click. I then reapplied the mod to cart_status.tpl and it also worked fine so I must have done something to corrupt this page, but all is better now. Thank you.


O.K. I was wrong I am still having problems.

I redid the entire mod on backup files and I even had the database reset to before I had the problems. I am hoping that someone out there could check to see if I am right on this problem and it just isn’t my connection or something. A link to one of my catagories is: [URL=“”][/URL] If I am right on this problem does anyone else have an idea on how to fix this. I appreciate the help.


Definatly something wrong there…

Sorry my error was with the javascript cart, as I dont redirect to a secondary page… Wish I could help but ive not really looked at it from that perspective

Anybody has any answers to this problem? I am experiencing the same thing.

When adding to cart the first time using javascript cart, it’ll say that the cart is empty. But second try is ok.

Please help.


I never really did figure out the answer, but I did end up fixing the problem. I fixed the problem by switching Ajax on and then doing the Ajax fix for the Thumbnail,Product info & Delete in Cart Sidebox mod post #22. I hope this helps.