Can't edit variants in global option

Hi, I have the one global option that’s large (it has a lot of variants). Recently when trying to edit the variants, it goes to a blank page after clicking “Save” and does not save my changes. The URL of the blank page it goes to is my admin dashboard, and it’s blank.

Hi Brennie

I have a similar issue on a different version - when I want to change a variant details I have to change the number of variants listed to 10 per page. Not saying this will work in your case but its worth a try.


Hi Barry, where do I change the number of variants per page?

It's usually in the config.php file.

I don't see anything in the config.php file regarding option variants. Is it worded differently? I checked congig.local.php as well & nothing related in that one either.

Anyone have any thoughts on this? I need to edit my variants but I can't…

Hi Brennie

My issue is with extended feature variants on 2.2.5, but it doesn't matter where I change the number of listed items displayed, Example if I change number of products displayed to 10 per page this is replicated in features and I can amend and save the feature variants. If I've got the number listed per page set at 100 I can't save the changes to extended feature variants.

It's worth a try.


I've already had my number of products per page set at 10.

Hmm I found the problem so hopefully CS-cart is reading because it may be a bug?

Previously I changed my php version from 5.2 to 5.3 to work with the latest version of cs-cart in a subfolder (the new version wouldn't work with 5.2). On a hunch I just changed it back to 5.2 & tried editing my global option again & this time it worked. Is this a bug?

Well I am back to this problem again, only in 4.0.2 version with my php version at 5.3 (has to be at 5.3 or greater for cs-cart 4.x.x). I'm adding my option variants and save, and it goes to the admin dashboard without saving my changes. Any thoughts on this in 4.0.2?

I received this response from support:

[quote]Also, I suppose that the issue is in the server configuration which limits the request which the store system sends. Please contact your store administrators and ask them to increase the value of the post_max_size server directive.[/quote]

I had to reply that I am the store administrator, please tell me where to look for that and what to change it to. Why wouldn't they have included that in their response? Who else would be contacting them other than the store administrator? They should keep in mind that they are on off hours from many of their customers, which means each response that doesn't answer my question and I have to shoot back a response for more clarification, is another day I lose because I have to wait until MY next morning to get THEIR next response.

Server administrator, not store administrator.

Ok thanks for clarifying for them. I'll contact my hosting company.

Edit: Turns out it's a simply change we can make in our php.ini file.

Ok maybe not so simple. I edited it in my php.ini but am still having the same problem.

Well I started this support ticket on 10/6 and it's still not resolved. That's 8 days my site is stuck in limbo. This is my most important option for my products. I make scented candles and this is my fragrance selection. I've only been able to add fragrances A - C (and only partially through the c's).

Cs-cart, can you hire more support people? Maybe some that work different shifts so you have 24 hour support?

We hit a cap on variants also. I think it was around 600. If we add one more all stops working. I submitted a ticket and they blamed the server. To this day it is still unresolved.

WELL after waiting days, THIS is the response I received from support. NOTE THAT I STARTED THIS TICKET on the 6th!!!


We will contact you at the first opportunity. However, I am afraid that our technical support department is loaded heavily at the moment. You should expect our answer not earlier than in 2-3 business days. We apologize for any possible inconveniences.[/quote]

[quote name='Brennie369' timestamp='1377495398' post='167358']

I've already had my number of products per page set at 10.


Hi Brennie

I was just re-reading this thread and just wanted to clarify, I wasn't referring to the number of products per page (setting in Appearance) to be displayed on the front end, I mean number of products listed per page in the admin area.

Hope you get to the bottom of this soon.


Hi Barry, where do I change that setting? I can't find it in config.php or config.local.php.

Hi Brennie

It's not a setting as such - just on your product list in admin you can change how many products you see per page. Admin > Products > Products. At the top of your product list you can see Total items (at least that's how it is in 2.2.5), ie how many products you have, and another figure showing how many are listed per page. I have to change the number listed to 10 if I want to go and make any changes to feature variants. Pretty sure there is a setting somewhere to permanently change the number listed to whatever you want but for most of the time I prefer have have my products listed at 100 per page as I don't change the variants that often.