Cannot Open Storefront After Upgrade Attempt


Can you guys please help me figure out how to open my storefront after a upgrade attempt? I have tried deselecting and saving the “Close storefront” option on the “Settings: General” page. I've also used a different computer to try to access website, so it shouldn't be a cookie issue.

This error occurred after I tried to upgrade my cart from 4.1.5 to 4.2.2. During this process, the upgrade seemed to timeout and my “/?version” check shows I'm still on 4.1.5. The upgrade center now shows that I don't have any upgrades available though.

I would really appreciate any help I can get as I don't have an active site right now.

Thank you!

First try clearing your cache from admin or

you can you revert the upgrade, in admin>upgrade center>installed upgrades>revert upgrade

or you could try first to delete the contents of the var/compiled and var/cache folders


Hi John,

You're suggestion wasn't exactly the fix, but you headed me in the right direction. I was able to refresh the packages list, which enabled me to try the upgrade again which then worked. I was then able to successfully open my store, now on version 4.2.4.

Thanks so much!