Cannot assign a new category or supplier to a product

Hi,

I'm currently working on upgrading our v3 site to 4.0.3.

So far I've done a clean install of 4.0.3. I've imported all the data and products using the store import addon. I've been in the process of migrating the skin/theme and fixing up my own addons to work with v4.



Everything seemed ok until today… I Tried assigning a category to an existing product. On the product page when I click on 'add categories' nothing happens (the popup is not opening).



Also, I cannot change the supplier. When I select 'supplier' the supplier box shows up, and says 'loading', the supplier list never loads.



It works ONLY when I create a new product. But once I save it I cannot change the supplier or categories.



Does anyone know what could be preventing these 2 things from working. Any help would be greatly appreciated.



Thanks!!

mod_security running on the server?

Hi StellarBytes



mod_security is not installed on our server.



I might have to do another clean install to see if this was a problem right from the start (before I did the store import)



It's weird how it only works for brand new products that haven't been saved yet.

on a clean install (before store import). it works fine.



I'm now trying to do the store import to see if it stops working after that. (However I'm having major issues now, the import stops half way at 'converting orders'. I had no issues a couple of weeks ago when I did it the first time. So now I'm stuck)

I figured out what the issue was finally!! (why I couldn't add a category to a product or change the product's supplier)



It's because i had “Template debugging console” turned on. When this is turned off it works fine.



CS-CART DEVELOPERS PLEASE CONFIRM, THIS LOOKS LIKE A BUG.

(I tried replicating it on your demo site, but I cannot enable the template debugging console)



I was getting this error in firebug when the 'edit product' page loaded…


ReferenceError: _smarty_conso is not defined
_smarty_conso