Can't write template cache on IIS

Hello all,

I have CS-Cart 3.0.2 installed on IIS7 running mysql 5.3. Everything is working properly but when I enable or install addons I get an error (SEE ATTACHED IMAGE).

I've set the correct permissions on the /var/ folder.

I noticed when trying to navigate to that folder from within explorer I get “Access Denied” error from windows if that tells you anything.

If I reset IIS everything works properly again.


I had this same permission issue on II7. You need to go into permissions and manually ADD the IUSR account and then set permissions accordingly. Making changes to the existing IIS_IUSR account wont cut it. Not sure why this is but it fixed the issue.

I am having the same issues with CS-Cart on IIS7, Server 2008 R2.

When I try to use ?cc URL via CS-Cart v3 to clean the cache my site will not show and gives an “error_occurred” error message on a white screen. The same thing happened when I was trying to uninstall and re-install the SEO module.

Same as the original poster, the “var\cache\templates\admin” folder from within Windows explorer gives an Access Denied error, permissions aren't visible, and I can't access the folder in any way. The strange thing about the folder - it is only 0KB and it can't be deleted normally. The only way to remove it is to restart the application pool for the site in IIS, upon which the 0KB folder goes away and gets reset to normal and the site functions once more.

I tried changing permissions for IIS_IUSRS group to chmod 777 for var by giving it full control to the var folder. That didn't work.

Then I tried giving the IUSR account full control over var and that didn't work either.

The installation document [url=“CS-Cart Documentation — CS-Cart 4.15.x documentation”]CS-Cart Documentation — CS-Cart 4.15.x documentation doesn't mention anything specific for Windows / IIS users, what am I missing?

I have figured out the solution to my problem. My php.ini file for PHP 5.3 had wincache enabled via the line extension=php_wincache.dll, so I commented it out and restarted IIS. Voila I could now clean the cache folder via ?cc just fine.

I read this thread to find out about the bug.

Further research from here shows you can enable wincache but turn off wincache.fcndetect, by adding wincache.fcndetect=0; to php.ini. That also fixed the bug and left wincache functional.