Can't edit or add to Product Feature (variant)... all of a sudden?

Hi -

I have a list of manufacturers set up as a product feature (linked to a filter drop down menu)…

I have about 70 manufacturers listed - and occasionally (once every few months) I add a new manufacturer.

However when I tried to add a new manufacturer 'variant' today, CSCart allows me to input all the data but on checking after saving, the new manufacturer isn't there? … the same is happening with changes to existing manufacturers - I've tried making a simple change to a name (just to see if it works), but the changes aren't saved.

I've checked the database in phpMyAdmin and the changes are not showing there either (so it's not a chache issue)…

Any ideas?? (there have been no changes to the server or CSCart this year - and I successfully added new manufacturers earlier this year).


CSCart 2.1.4

Hello Fishpaste,

Thank you for your message.

It seems that the issue occurs because a POST request which is sent when you click the Save button is quite big and it is cut on your server according to some directive. I suggest that you should check the following directives:

  • post_max_size - increase the value of this PHP directive on your server to the maximal possible one;
  • max_input_vars - set this PHP directive to 2000 or more (in case 2000 is not enough);
  • if your server works with using Suhosin, increase the value of the suhosin.request.max_vars directive to 2000 as well. You can also try disabling Suhosin on your server.

    Please check these recommendations.

    Thank you.

    Pavel Zyukin

    CS-Cart Support team


I have a similar problem to this and am interesed to know if you have tried the CS suggestion and if it worked?