Bug in the SEO addon???

When I create a new page and the SEO name starts with the word ‘test’, I get a 404 error. When I edit the name and just replace the word ‘test’ with something else the site shows up.



An example at [url]http://www.cscartdemo.martfox.com/[/url]



Go to the ‘Top menu > Company’ and try the links Test Page 1, Test Page 2 and Page 3.

I had this same error with a different word, that is the main product of my business, and is completely unrelated to anything ever said or used in programming. I couldn’t figure out why this page and only this one page would return a 404 (other than the word) so I had to rename it. Oddly, it only happened with that single word, if I renamed it to anything else and still had that word in it, with a dash or not, it would work.



Oh and it worked for almost a full year as just the “word” as the name. I noticed it just before going live, which was also right after I made the upgrade to 2.0.15. I’m pretty certain that it worked all the time prior to that. So perhaps some changes were made in 2.0.15 that have remained unchanged since.



Edit: Someone else was also experiencing this sort of bug recently too: [URL=“http://forum.cs-cart.com/showthread.php?t=21436”]http://forum.cs-cart.com/showthread.php?t=21436[/URL]. I see that he still hasn’t fixed the “uniform” category from returning a 404.