Authorize.net Card Being Declined Because of Incorrect Information

Okay so this is the issue I am having:


  1. Customer places order but puts an incorrect CVV2
  2. The order gets declined
  3. Customer goes back to fix the incorrect CVV2 and places the order again
  4. The order gets declined again because cs-cart is using the same incorrect CVV2 for the second attempt as well



    Is there any way to fix this problem?



    Also when a customer puts an incorrect expiration date the entire order gets declined. Is there any way to inform the customer to fix the expiration date so the order can go through? Is there any way to add a drop down menu for the expiration date field because that would minimize this error?



    This is a really big issue because the above problems happens every single day.



    Any help would really be appreciated.

On the cvv2, out customers are able to do this. I do remember having an issue with an older version, but we are using 2.2.3 right now and it seems to flow fine.



On the year, I would have to agree that a drop down is needed. At least a couple of times a week a customer will try to type in “2013” instead of just putting in “13”. So the system things they put in “20”. If it was a drop down we could easily avoid this and keep customers from getting frustrated.

So on version 2.2.3 your customers are able to go back and edit the cvv2 and expiration date and cs-cart uses the corrected digits instead of the incorrect ones?



I'm currently using 2.1.0.



Cs-cart should really sell their software without any bugs at all rather than having the merchant lose sales and fix the issues themselves.



Hmm…You are right I have had several customers with the expiration year of '20 so that is the reason why. A simple drop down menu should have been added at this point.

[quote name='heyheyhey' timestamp='1321322779' post='125991']

So on version 2.2.3 your customers are able to go back and edit the cvv2 and expiration date and cs-cart uses the corrected digits instead of the incorrect ones?



I'm currently using 2.1.0.

[/quote]



My guess is you should at least update to 2.1.4 as I know that we did not have this issue in that version. I kind of skipped over 2.1.0 so I couldn't tell you how to fix it.


[quote name='heyheyhey' timestamp='1321322779' post='125991']

Cs-cart should really sell their software without any bugs at all rather than having the merchant lose sales and fix the issues themselves.

[/quote]



Have you not purchased software from anyone else? I've never purchased software of any kind that did not have some type of bugs. CS-Cart is no exception.


[quote name='heyheyhey' timestamp='1321322779' post='125991']

Hmm…You are right I have had several customers with the expiration year of '20 so that is the reason why. A simple drop down menu should have been added at this point.

[/quote]



Yes, the drop down would be nice. In my mind, they had this in the past but I may be thinking of one of my other shopping carts.