Amazon Payment Icon

For some reason my Amazon Payments icon doesn't show up on my cart page. I can see the code, but not the icon. Has any one else had this issue and knows how to fix it?



Thanks,



Brandon

The icon image link works?

[quote name='brandonvd' timestamp='1401747764' post='184890']

For some reason my Amazon Payments icon doesn't show up on my cart page. I can see the code, but not the icon. Has any one else had this issue and knows how to fix it?



Thanks,



Brandon

[/quote]



I do not see even the code on your store.

Sorry guys, I've been out of town.



This isn't for my saltwater site, it is for a different one. I was just kind of hoping that someone had ran across this before. The whole icon and code and everything isn't showing up. I have the “or” thing, but nothing below it on the cart page.



Any ideas?



Thanks,



Brandon

[quote name='brandonvd' timestamp='1402251338' post='185327']

Sorry guys, I've been out of town.



This isn't for my saltwater site, it is for a different one. I was just kind of hoping that someone had ran across this before. The whole icon and code and everything isn't showing up. I have the “or” thing, but nothing below it on the cart page.



Any ideas?



Thanks,



Brandon

[/quote]



Please PM me the URL to your website.

I am having the same issue, I see the code but the button does not appear. Did anyone ever figure out a resolution to this?

I have the same problem, no code, no button.



I created a support ticket with CS-Cart, and authorized them to use support credits to fix, I am on a brand new install of 4.2.2. Waited 3 days and got the response that the Amazon button only shows up on the view cart page, to please re-check it.



I know how the button works, would have been nice if they took 5 seconds to actually look that it wasn't there before replying.



I responded and let them know it isn't there, that was 3 more days ago…silence…

Anyone get a resolve on this… We are just now starting to implement this payment feature and also we cannot get the button to show up.

I had this issue re-appear after an update, there is code modification required in the amazon_checkout.php file at line 151

Apparently the default button is coded for non-US button.

    if (empty($_payment_id)) {
        $_payment_id = '0';
    }
    $checkout_buttons[$_payment_id] = '
' . '

';

Mine works now, I have tested it. Hope this helps, this has been this way since 4.0 not sure why they don't post the solution or offer options in payment configuration for US.