Amazon Checkout shipping options

Is there anyway to specify the default shipping method when amazon checkout is the payment method? For some reason it defaults to our most expensive option, fedex 2 day. We checked the order in the cs-cart shipping method and we have Priority mail, feded ground, 2day as the order. I don't see anywhere how to change this.

Bump, anyone?

I've narrowed this down to only affect customers from California and I think that it has something to do with tax. Only CA residents are charged tax in our store. When they checkout with amazon, fedex 2 day is the default shipping option instead or ground. But if any other state is chosen, fedex ground is the default. Any ideas?

I have had Amazon support look into this and this is what they determined


[quote]

Our engineers think they may have found the root cause behind this error. Your cart is requesting a callback to calculate shipping on its own–this is an example of one of those callbacks:



http://payments.amazon.com/checkout/2009-05-15/”]http://payments.amazon.com/checkout/2009-05-15/[/url]”>









pinktvinkn
AddressId>







objects-Objects22

tax_default



FedEx Ground 2-6 days

Fedex 2nd day 2 days plus production time







urban-military-jets

tax_default



FedEx Ground 2-6 days

Fedex 2nd day 2 days plus production time

















tax_default





0

WorldAll













cart-discount

Discount





0

USD













FedEx Ground 2-6 days

Standard





9.5

USD







WorldAll



FedEx Ground





Fedex 2nd day 2 days plus production time

Standard





30

USD







WorldAll



Fedex 2nd day





cart-discount





If you'll notice, you're sending back two ShippingMethods. Both of these ShippingMethods have this in them:



Standard



CBA defaults to whatever shipping level has a ServiceLevel of Standard. Since you have two of these, it's reverting to the second one (as it was the last one that was parsed through the system). You should only have one of each ServiceLevel per cart. The other acceptable ServiceLevels are: “TwoDay”, “OneDay”, and “Expedited”.



Could you switch the ServiceLevel of the 2-day shipping option to “TwoDay” and see if that works?

[/quote]



How would I make those changes?