after upgrade to 2.0.10 shipping not found

i upgrade to 2.0.10

i get message when user tries to checkout …

Unfortunately no shipping options are available for your location.

Please contact us and we will see about delivering to you.

all shipping methouds have all checked …

unchecked and saved and rechecked and saved …

still can not get past shipping in cart checkout .

Did you check the user groups on the shipping settings?


Speed seems about the same for me for pages already cached. The update clears your the template cache as I recall.

I am testing a 2.0.9->2.0.10 update and have only found small issues so far. Next up, a 2.0.8->2.0.10 update - be interesting to see if that has more problems


[quote name=‘teksigns’]the way that i was using the manual shipping before in 2.08 was

putting my shipping charge for each item in the shipping freight box

when editing the item …

I had a manual shipping setup . with 0.01 in the More than box under Cost dependences for the usa …

worked fine before …

does not work at all now . no mater what group i assign …[/QUOTE]

This setup works for me (2.0.9 upgraded to 2.0.10).

Are using the supplier addon? If so, don’t forget to set the supplier on the shipping method.


Problem solved with shipping …

hope this does not happen to anyone else …

for some reason the upgrade from 2.0.8

knocked out part of my shipping address …

i never check the shipping address cause i always leave it the same …

but i clicked the ship to different address and there was no state in the box…

the state got missing ???

strange …

Hi Teksigns - we are having this problem as well. So far the only thing that works is if the customer chooses ‘Ship to different address’ on the checkout page. If they keep the shipping address same as the billing address, they will get the error:

“Unfortunately no shipping options are available for your location.

Please contact us and we will see about delivering to you.”

Were you able to fix this?

Just an update - after verifying that all settings within the admin were correct, the problem still persisted. Did a cold-boot on my computer and shipping just started working for what ever reason. Running Win7 and latest version of FF.

After upgrading to 2.0.10 it appears there is a problem with the “States” field as now none of our registered customers state is shown in either the billing or shipping addresses! It just shows as never being chosen during the initial registration.

Also, after I set the State field for a customer, it is now displayed with a preceding underscore like this: __PA

Does anyone know how I can fix this?

It’s a bug, check the database for anything __PA (Which is your state I presume) and change it to “PA” I can’t tell if this just effects new installations however I can’t tell otherwise.

My suggestion is to change the country dropdown menu to something else, clear the state and then save and change it back.


Thanks for the reply Jesse!

I upgraded from 2.0.8 to 2.0.9 to 2.0.10, there were no error messages whatsoever during the upgrade!

Now none of our previously registered customers “state/providence” field was saved during the upgrade & now shows “Select State” for both billing & shipping address.

I just checked the “states” database table and all entries are fine in the db. Now when I go in & set the state within a customer profile to PA (Pennsylvania) for example, it appears correctly in their profile as PA, however, it appears that CS-Cart is storing the states field details as _PA with a preceding underscore! Also because of this no realtime shipping rates are being returned.

Also, when I view a test order through the admin panel, it appears like this with the preceding underscore (or 2 underscores):

Joe Tester

101 W. Main Street

Conyers __GA 30094

United States

I am in the process of trying to reset the country USA and states to see if this will help, no luck so far.

Any other ideas anyone may have is appreciated!

Fixed: [url][/url]

& Don’t forget to bow! :smiley:

Thanks alot Jesse!

I just spent 3 of my 4 holiday weekend days searching for the source of this flippin problem! Basically, none of our customers could get an order to go through because the realtime rates would of course stumble on the “State” Field for every one of our customer addresses. CS-Cart would either show the state field as __CA, or I would go in and set the state and come back an hour later and it would be blank again as in -Choose State-. :confused:

This was a total nightmare! :rolleyes:

The file you are referencing in the Bug Tracker, is this it?


Thanks Again!!

Both admin and customer I would imagine.

[quote name=‘Tool Outfitters’]Both admin and customer I would imagine.[/quote]

What he said ^^

Thanks Guys!

BTW, I am really shocked that knowone else other than myself & Jesse has experienced this (or is perhaps aware of the problem) yet.

I was not sure if I somehow caused this during the upgrade from 2.0.8 to 2.0.10 (although both stages of the upgrade appeared to go flawlessly), or, if it was truly a bug. And considering only myself & Jesse made any mention of the issue, I was hesitant to add it to the bug tracker.

I cannot reproduce the problem but I do notice that if I select a different country, the states do not show for the country selected.

Hello Tool,

Here is some more of the strange behaviour I am seeing:

If I go to one of our existing USA customer profiles and change the country to some other, the US state will remain, however, it displays as __PA

Ir-relative on who experiences it, We still have the 2.0.10 release of CS-Cart with the associated extra gaps. The company I work for still received orders (God knows how) but when I went to manually create an order from the customer side you can clearly see that after inserting the shipping/billing information: once the screen goes to shipping method the customer profile will have __STATE shown.

To my knowledge, everyone has it since it’s in the release :wink:

Yes, the states do not change from US. Does implementing Jesse’s fix do anything for you?