After changing to Thumbnail format, no product images /Thumbnail

Hello,

I tried to use default cs-cart - settings -Thumbnail format as WEBP, but after I save the changes, no image is showing on website and load time is very high. Why?

I can assume that the system tries to generate webp images “on the fly” but failed to do it for some reason. Please make sure that the imagick extension is installed on the server and configured correctly

Is it because I also have an add-on that does the conversion and works fine CS-Cart add-on - WebP images conversion but I would also like to test the default built in function. I disabled the addon but still the same result.

What web server are you using, Apache or Nginx? Please check if its current configuration allows the .webp extension.

PHP-FPM is used as a Backend server and Nginx stays as a Frontend one. I installed imagemagick with webp and works fine with my add-on, all images are converted to webp and works. The only issues is when I try to use cs-cart Thumbnail webp

In case you are using nginx configuration from our documentation, then in the following lines of the config:

        location ~* /(\w+/)?(\w+/)?(.+\.(js|css|png|jpe?g|gz|yml|xml|svg))$ {

and

    location ~* /(\w+/)?(\w+/)?(.+\.(jpe?g|jpg|webp|ico|gif|png|css|js|pdf|txt|tar|woff|woff2|svg|ttf|eot|csv|zip|xml|yml))$ {

try to add webp to the list of matching extensions.