Admin can't login. Cleared caches, browser, etc.

Not sure what is happening. When I try to recover my password it lets me log in with the link but when I change it, it reverts back to the old (assuming temp) password (I can tell because the character length doesn't match my new one). If I log out and try to log back in it just continually loads and ends up with several mysql errors on line 71, 140, 149, etc. (if I put in the correct password). The page disapeared before I could copy all the erros. If I put in the wrong password it instantly tells me it is wrong. I have tried clearing the cache, cookies, different browsers, and a different computer with the same results.



What is going on?!?!?!

Here are the errors that pop up after about 5 minutes of trying to load:



Warning: mysqli_query() [function.mysqli-query]: Couldn't fetch cmysqli in /home/fastdeca/public_html/shop/core/db/mysqli.php on line 71
Warning: mysqli_errno() [function.mysqli-errno]: Couldn't fetch cmysqli in /home/fastdeca/public_html/shop/core/db/mysqli.php on line 140
Warning: mysqli_errno() [function.mysqli-errno]: Couldn't fetch cmysqli in /home/fastdeca/public_html/shop/core/db/mysqli.php on line 140
Warning: mysqli_error() [function.mysqli-error]: Couldn't fetch cmysqli in /home/fastdeca/public_html/shop/core/db/mysqli.php on line 149
Warning: mysqli_errno() [function.mysqli-errno]: Couldn't fetch cmysqli in /home/fastdeca/public_html/shop/core/db/mysqli.php on line 140

Well for whatever reason the password started working. I hit the forgot password link but didn't actually click on the link in the email it sent. After that the password worked fine. Not sure why. Still concerned about the mysql issue though.