Add button is not working on product page

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]My add button (and the wish list button too) are not working on the product page. But it works well on the category listings.[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]I have not modified any code so it’s really weird.[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]Any help ?[/size][/font][/color]

[color=#282828][font=arial, verdana, tahoma, sans-serif][size=3]My version is 3.01 PRO[/size][/font][/color]

Hello Pascal,

Thank you for your message.

It seems that this problem occurred because of a well-known bug in the current CS-Cart version. Please apply the fix provided in the following issue of our Bug tracker and check whether your problem is resolved after that:


Thank you.

Pavel Zyukin

CS-Cart Support team

Hi Pavel,

Thanks for answer as it seems it's exactly the error I get.

I tried to deal with the diff file, but it give me error so I am not able to apply correction.

Is it possible for you to send me by mail or link the modified files ?(b/skins/basic/customer/blocks/product_templates/default_long_options_template.tpl and b/skins/basic/customer/blocks/product_templates/default_template.tpl).

Hello Pascal,

Thank you for the reply.

Sure, please contact us via Customer Help Desk so that we can provide you with the necessary files. Or we can fix this problem directly on your server if you wish. In this case please provide temporary access to your server by clicking on the Add record link on the Access information page of your Help Desk account so that we could fix it for you.

Thank you.

Pavel Zyukin

CS-Cart Support team

I have also the same issue. Cant use the add to cart button on product page. Can I get also the correct files to solve it?

Also having problems with my products. There is 1 missing and if I make a clone, it will not be shown on the frontside of the store.

I have solved it by deleting the whole website incl. the database. And installed now V3.02. Only have to start all over again. Hopefully this will never happen again.

I've disabled the[color=#0000cd] [/color]Check for updates automatically[color=#0000cd] in "Properties: General[/color]

Hopefully this will solve this issue for the future.

If anyone has any ideas, please let me know.