500 Internal Error when clicking Sales Reports

I was changing a few things in a few different .tpl files that had to do with the sales report. I was changing a few others things too (unfortunately I can’t remember specifically), but now whenever I click “Sales Reports” it takes me to a 500 Internal Error page.

From the forums and the manual, it tells me that this is due to permission problems, but everything that I remember changing is 644 or 755, and I don’t see any files that would not allow access. I’ve restored the backups of these files that I’ve made, but no luck. I’ve even gone on to replace the entire “basic” skin that the admin panel uses. Still no luck. I’ve restored backups of the sales_report.php controller and the fn.sales_report core file. It still gives me the same error. Could this be a database problem? I did backup the entire database on the day that the error started happening.

Any ideas or possible fixes or ways to find a solution would be greatly appreciated! Thank you.