404.html Not Working

Hi guys,

I've been working on this custom 404 Error page for days and i can't seem to get it to work.

I have created a 404.html file which i then uploaded to the my public/html folder in cpanel along with the image that goes with it. I then entered the code ErrorDocument 404 /404.html up the very top of my .htaccess page and i still can't get the page to work.

I also tried using this code…

[color=#000088]if[/color][color=#000000] [/color][color=#666600]([/color][color=#000000]$status [/color][color=#666600]==[/color][color=#000000] CONTROLLER_STATUS_NO_PAGE[/color][color=#666600])[/color][color=#000000] [/color][color=#666600]{[/color]

[color=#000000] fn_redirect[/color][color=#666600]([/color][color=#660066]Registry[/color][color=#666600]::[/color][color=#000088]get[/color]color=#666600[/color][color=#000000] [/color][color=#666600].[/color][color=#000000] [/color][color=#008800]“/404.html”[/color][color=#666600]);[/color]


in the fn.control.php file but still no success.

Not sure what's going on but it really is doing my head in as I am trying to do an SEO audit on my page and Google are really strict with 404 pages.

THis is the error i am getting on my screen when i try to test the 404.

[color=#000000][font=Times][size=1]No controllers for: _no_page[/size][/font][/color]

[color=#000000][font=Times][size=1]Thanks guys.[/size][/font][/color]

Do you know that custom 404 page can be created by the built-in block manager?

Is that available in version 3.0?

I've got the page all set but just wont work

[quote name='venomxr' timestamp='1421239392' post='202571']

Is that available in version 3.0?

I've got the page all set but just wont work


I have just checked 3.0.6 version and this location exists there. Try to replace your current .htaccess file with the default one

Where do I find the default .htaccess file? Thanks

Why is it that when i type a fake url that ends in .jpeg my 404error page works fine yet when it ends in .html it gives me a “no controllers for page” ?

[quote name='venomxr' timestamp='1421261327' post='202611']

Where do I find the default .htaccess file? Thanks


Please try


DirectoryIndex index.html index.php

RewriteEngine on

Pleas note that RewriteBase setting is obsolete use it only in case you experience some problems with SEO addon.

Some hostings require RewriteBase to be uncommented


Your store url is http://www.yourcompany.com/store/cart

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !.(png|gif|ico|swf|jpe?g|js|css)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php?sef_rewrite=1 [L,QSA]


i added the code into my .htaccess but no good.

I have both my 404html and the png image that goes with it in the public/html in cpanel along with my .htaccess file.

I'm not a coder or computer expert so I do apologize of any stupid questions or answers

Still can't get this 404 error page to work. I don't know what made me do it, however when i clicked my url.jpeg my 404 error page worked great but typing anything causes and it just turn into a blank white page with the “no_controllers for this page” message up the top.My url is uniqueautoart.com for those who want to try it.

It is required to examine the issue directly on your server. Please contact CS-Cart support team