4.2 admin broken

I have 4.2 site and it works fine on the customer side. On the admin side, however, a bug has developed somehow and certain functionality has been broken ever since. This all seemed to stem from cs-cart suspending my license when I turned on a second storefront for testing. I wanted to make sure the additional storefront would work properly before I paid for a second license. They have since informed me that there is no option available for testing other than installing on a test server. That's fine, but in suspending my license it seems to have broken something.

First of all, I am now unable to disable the second storefront (which did not work btw). In fact, I can't even see it in the list when I choose ADMINISTRATION>STORES. In addition, the (+) button that is used to add storefronts is not visible at all. Furthermore, up at the top left where I used to be able to select ALL STORES or any individual store, there is no dropdown like there used to be. So I am stuck on the first storefront. Again, no option to select ALL STORES, it is broken.

So cs-cart tells me to simply select ALL STORES and then I can disable the second storefront. Needless to say, this does not solve my problem. They have turned on a second license temporarily for me, in hopes that would allow me to edit that second storefront, but it did nothing to resolve the issue.

I get the pop-up saying that an upgrade is availabe, but I receive a 403 error, access denied when I click it.

There's more. Now I can see no UPGRADE CENTER link under ADMINITSRATION. There are other missing links as well. Under LANGUAGES, I cannot edit, nor add new languages. When hovering over the checkboxes all I see is a red “anti” symbol. Another thing broken.

So, today I received a response from them and the included screenshots show that when they log in all functionality is there. I have tried clearing temp files on my machine, but to no avail. I have also tried logging in on a different computer, but same issues.

I'm tired of waiting on them to resolve this, so I am posting in hopes that someone here has an idea of what I might try next. Cs-cart suggested that I do not upgrade until this is resolved.

Any ideas?


well after almost two weeks of back and forth with cscart helpdesk, who in turn referred me to my hosting provider, all in the hopes of resolving my broken admin, I finally got a simple answer that fixed things.

Today I received a reply that everything was working as intended and I only needed to find the root administrator to log in and he would be able to “fix things”. Well funny that I have been the only administrator for over two years and the functionality that broke a couple of weeks ago was working fine previously. I see it as they turned a switch of some sort, which in turn downgraded my admin account. That would have been fine, but no one there could seem to provide that simple answer until this morning. sigh

terrible service