4.0.2 Install Fails Silently

I am attempting to do a first time install of cs-cart 4.0.2 and have followed the installation steps to the letter and when I click on the “Install” button in step 2 the modal with the progress bar pops up briefly (for like a second) then disappears. Nothing else happens. No error, no warnings, nothing…

I have tried the install in 3 different browsers and all have had the same result. I have also tried to install with the demo data and without it.

The host has confirmed the file permissions are set properly and I have verified all of the DB info and other settings…

I am completely baffled and out of ideas anyone have any thoughts on what might be going wrong here?

** Resolved **

It seems that the database user permissions didn't take on the server. The DB user was showing it had the proper permissions, but they didn't actually exist. Once I re-saved that particular DB user and ran the installer, the cart installed fine.

So the moral here I guess is even though the server “shows” that permissions are set a certain way, triple check and if necessary swear at cPanel ( It helps, honest ).

I'm having the same issue and I tried doing what you said, but it still doesn't work.

[quote name='knoxbury' timestamp='1381172659' post='169328']

I'm having the same issue and I tried doing what you said, but it still doesn't work.


Sorry to hear that Knoxburry, try reviewing all of your permissions… Files, database user(s), everything… You could even call your host and have them double check them just to make sure all of the permissions took the change, especially if you are using an FTP program to change the file permissions…

I have reviewed all that. Should it really be THIS difficult?!