4.0.1 Theme Editor (Customize Theme) Disappeared

Hi All - either this is a weird bug or I am missing something. This is a fresh install, I used the theme editor to begin with, worked great, made all my changes. Then I went to work setting up the store and set up My Addons using mystyles.css.

I have not modified anything.

So I go to adjust something in the theme editor, and it pops open the store front but the editor (the interface that slides in on the left side) does not show up at all.

Has anyone had this happen?



I've had it happen a couple of times if I have another tab open with the store on it. Pressing F5 to refresh the page always gets it back for me.

Thanks for the reply. I tried that, I tried other browsers, cleared all cache from admin and front end and browser, rebooted…still the theme editor does not show up…

I had the same problem when I installed with the demo data.

played with the theme editor and then and went a tried few other features of the cart.

Went back to play with the editor and it had disappeared of the side. Tried a different browser no luck.

I had deleted the other store as i didnt need it so added another store just to see if that was the problem and then it all seemed to be ok after that. Could have been that but that seemed to do the trick. deleted the second store and it still works.

Definetly a problem though that needs to be looked at.

Thanks for the reply! You are right! I too installed with the demo data, and I too deleted the acme store, and now I am guessing that is when the theme editor disappeared. So I added a dummy store, then the editor worked, so I made my changes, BUT, once I deleted the dummy store then the editor does not show up anymore, so its definitely a bug. So glad I got this far on it as I have my colors back and I was going nuts trying to figure it out.

By the way, does anyone know where the presets are stored? The three default presets are stored in design/themes/basic/preset/data/ but once you make changes you need to rename and create a new preset, and although I see that preset in the DB I can not find anywhere the actual .json file. I would think it would be with the other three.

I will submit it to Cs-Cart and see what they have to say.


Confirmed, I have same problem too. 4.0.1

I posted this in Bug Tracker…so CS cart is looking at it. Thanks for confirming!


We too are facing the same issue. A black column comes at the left hand side and nothing is being displayed. We are on v4.0.2 and have made some custom changes using the My Changes addon.

What should we do?