Jump to content

tyzy808's Content

There have been 2 items by tyzy808 (Search limited from 26-Sep 20)

Sort by                Order  

#3544 Skins installation error

Posted by tyzy808 on 09 August 2006 - 10:55 AM in v1.x Installation & Upgrade

have you or any one solved this problem? i am having the same problem, the skin in the repository exists and the correct permissions are set. please post a solution if somone has it.

thanks alot

Okay, i believe I found a solution to my problem and hopefully it will help others who run into this. I had to modify the file, /core/fn_common.php, starting from line 1193, or the function fn_mkdir(). There is a foreach loop in the function, i've modified the code just a bit as i commented below. The problem was the ending slash being fed to the mkdir php function, which rejected it. I'm not sure why other people aren't getting the same error, perhaps due to the flavor of OS... i'm on a server running BSDi. Possible? Anyway, this seemed to do the trick.

foreach ($dir_arr as $k => $v) {
   // $path .= $v.DS; // original code
   $path .= $v; // modified code :: removed the ending foward slash
   if (!@is_dir($path)) {
     if ( @mkdir($path, $perms) != true) {
        $error = true;
   // added code :: Add the foward slash for the next iteration after the directory has been created
   $path .= DS; 

#3456 Skins installation error

Posted by tyzy808 on 04 August 2006 - 11:49 AM in v1.x Installation & Upgrade

The problem occurs after selection of a skin during the installation wizard. I recieve the following after selecting any skin:

Installing customer frontend base templates...
Creating directory skins/brickwork_yellow-green/customer...

ERROR occured while coping the files... Please check if skins_repository directory exists and has read permissions

I checked all the folder permissions, and all folders that should have read permission has read permissions... along with the folders existing.

Any help would be much appreciated.