Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Amazon Cdn Is Active Yet Test Shows Cdn Not Used Rate Topic   - - - - -

 
  • sap
  • Junior Member
  • Members
  • Join Date: 03-Oct 09
  • 100 posts

Posted 06 December 2017 - 02:25 PM #1

Hi

 

I am using Amazon AWS and CDN is active on my cart

 

Please see the screenshots

 

when I test my page load speed on webpagetest.org. it says CDN not effectively used

 

https://www.webpaget...un=2#use_of_cdn

 

However when I view the source for the page the same image is showing the cloudfront URL (please see screenshot here)

 

How is this possible and what am I missing here? Appreciate any help

Attached Thumbnails

  • Screenshot 2017-12-06 20.46.28.png
  • Screenshot 2017-12-06 20.46.52.png


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 10,053 posts

Posted 06 December 2017 - 10:01 PM #2

What you see in your source view and what webpagetest.org sees could be completely different based on how much of your data has made it into the CDN network and/or location the page is actually being served from.  Since most of your fails seem to be thumbnails, my guess is that they were dynamically generated and have not yet reached the CDN environment.

 

Trying to diagnose CDN can be problematic since it's basically location specific and odds are you're not at that location!


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • sap
  • Junior Member
  • Members
  • Join Date: 03-Oct 09
  • 100 posts

Posted 07 December 2017 - 01:14 AM #3

What you see in your source view and what webpagetest.org sees could be completely different based on how much of your data has made it into the CDN network and/or location the page is actually being served from.  Since most of your fails seem to be thumbnails, my guess is that they were dynamically generated and have not yet reached the CDN environment.

 

Trying to diagnose CDN can be problematic since it's basically location specific and odds are you're not at that location!

Thanks for your advice

 

It is strange since I am testing this in the US and AWS has several locations there. Also there should not be such a delay in thumbnails reaching the CDN. I will re run the tests and see if it shows any difference

 

BTW, the test does recognise that AWS is being used for other properties on the page except that some thumbnails and scripts are being left out



 
  • sap
  • Junior Member
  • Members
  • Join Date: 03-Oct 09
  • 100 posts

Posted 07 December 2017 - 07:48 AM #4

On GTMetrix it says the CDN URL is redirecting to the store url

 

please see screenshot

 

Why is this happening and what is the fix?

Attached Thumbnails

  • Screenshot 2017-12-07 15.47.05.png


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 10,053 posts

Posted 07 December 2017 - 08:43 PM #5

I'm guessing it (AWS/cloudfront) doesn't like the cache tag being applied to the images.  I.e. ?t=somenumber


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.